Bug report : Cant open the game up? tryed the standalone and the Launcher.
You should be logged in to post a new reply.
August 21, 2013, 1:05 pm
Posts: 2
Hello Any one can help me.

i play on a macbook 17" i5

it wont open my game up. and the launcher dont wanna download the game! just 0.0 mb.

i tryede the browser game and still it wont play!

I tryed the stand a lone and it dont work.

WHAT now??

Hope some on got a ideer to what i can do or is missing.

August 22, 2013, 4:59 pm
Posts: 2
Any one got the same problem? or can help?

Best Regard
September 7, 2013, 7:09 pm
Posts: 20
got the same damn problem on 27" mac, can load the laucher but when i press start the game doesn't come up D: tried to mend it didn't work.
September 8, 2013, 11:46 pm
Posts: 346

We will had something to track this problem.

In the mean time, there are two things you might want to try:

- Be sure to install java 1.7 (the last version).
It can be found at

- Go to the Build & Defend directory
%userprofile%/.buildanddefend (for windows)
~/.buildanddefend (for linux and probably mac)

And remove the "bin" and "cache" directories.

Tell me if this solves (or does not solve) your problem.
September 9, 2013, 8:28 pm
Posts: 20
I installed java 7, didn't help.

Macs dont really have directories :L, but I unziped the Buildanddefendlauncher.jar file and couldn't find 'bin' or 'cache' not really sure what to do now :S
September 10, 2013, 3:25 am
Posts: 10
Don't unzip the .jar file. That is the game file that you run. Yes, it is a java archive file but you run it like an .exe. (i.e. Right click -> Open With -> Java 7)

The bin and cache folders are create in the .buildanddefend folder in your home directory. (~/ means home folder in Unix).

If you do not see the .buildanddefend folder when you open up your home folder, try going into your folder settings and make it show hidden files.
September 10, 2013, 7:47 pm
Posts: 20
i managed to show all hidden files, by using terminal, yet i still couldn't find the build and defend file.. not really sure what to do :S
September 11, 2013, 2:20 am
Posts: 346
Can you tell me what type of computer you have?
Is it powerful enough to play games?

Now, here is what you need to do:

1. Download the game (jar version)
2. Open a terminal
3. Go to the directory where you have downloaded the game.
You can navigate to the directory will the "cd [name of the directory]" command
4. Once you are in the directory, type "ls" + enter.
You should be able to see the file you have download.
5. Type "java -jar [name of the file with the .jar at the end]" + enter.
Of course, replace [name of the file with the .jar at the end] with the actual name of the file.
6. The game should start now. If it does not, copy the content of the terminal's window in the forum. This will help me to figure out what is wrong.

September 11, 2013, 8:35 pm
Posts: 20
Yes!!! we finally found it!, to get to the build and defend directory, open up terminal, type in "defaults write AppleShowAllFiles TRUE" then press enter. hold ctrl and alt, click on finder, then click relaunch. This allows you to see any hidden files in your mac. go to users, your name, e.g user/lowes/.buildanddefend, then tahdah. to hide all the hidden files type defaults write " AppleShowAllFiles FALSE", press enter, then ctrl alt click finder, relaunch.

however I deleted both folders bin and cache, updated the game from the buildanddefend_lancher.jar and the game still will not load...
September 12, 2013, 2:17 am
Posts: 10
Did you try running the launcher through the terminal like Achoum suggested?

Also, does the standalone version work?
September 12, 2013, 4:55 pm
Posts: 20
i followed the instructions as achoum said, the game still wont open and I got this:

lowes:Downloads Lowes$ java -jar buildanddefend_standalone_full.jar
Exception in thread "main" java.lang.UnsupportedClassVersionError: org/ninjacave/jarsplice/core/JarSpliceLauncher : Unsupported major.minor version 51.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClassCond(
at java.lang.ClassLoader.defineClass(
at Method)
at java.lang.ClassLoader.loadClass(
at sun.misc.Launcher$AppClassLoader.loadClass(
at java.lang.ClassLoader.loadClass(
September 13, 2013, 12:49 am
Posts: 10
Can you also paste what you see when you type the command below in the terminal?

java -version

September 13, 2013, 5:02 pm
Posts: 20
lowes:~ Lowes$ java -version
java version "1.6.0_51"
Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)
lowes:~ Lowes$

September 13, 2013, 11:55 pm
Posts: 10
Since you said you installed the newest java, it looks like your system is still using using java 1.6 as the default instead of java 1.7.

Try this: (I got it from

Open Java Preferences in /Applications/Utilities. Drag Java SE 7 to the top. It will now be your default JVM. Run java -version again, and you should see something like:

java version "1.7.0_04"
Java(TM) SE Runtime Environment (build 1.7.0_04-bxx)
Java HotSpot(TM) 64-Bit Server VM (build 23.0-b17, mixed mode)

Ignore the part about Eclipse, that's just a program for coding java.

If you do not see Java SE 7 then try googling how to install Java 7 for mac.

Hope that works.
September 14, 2013, 1:41 pm
Posts: 20
Thanks Goshyn and achoum, like you said java wasn't using the correct version. It took ages to get java 7 working but i got it on. I then refollowed achoum's points of using terminal to open up build and defend to update in terminal. anyway, it's finally working guys!!! :D
thanks again.

April 5, 2014, 3:22 pm
Posts: 5
I have the same problem, but Java 7 is the default version. I also tried running it from the terminal, but it said that it couldn't find the file.
April 6, 2014, 2:10 pm
Posts: 20
Maybe try downloading java 8, might make a difference :S. Other than that you could try and follow what achoum said. macs don't show all files so you will need to type in a command, something like showallfiles true. Then you should be able to find the build and defend file/folder. Just look at the previous instructions and you should be able to get it to work.

Good luck!

You should be logged in to post a new reply.